Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 0.5
    • Fix Version/s: 1.0
    • Labels:
      None
    • Environment:
      Any

      Description

      Log formatting errors occur at deployment of flexible JDBC realm.

      [#|2011-01-22T12:23:29.934+0100|SEVERE|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=11;_ThreadName=Thread-1;|java.util.logging.ErrorManager: 5: Error in formatting Logrecord|#]

      [#|2011-01-22T12:23:29.945+0100|SEVERE|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=11;_ThreadName=Thread-1;|java.lang.IllegalArgumentException: can't parse argument number cache.classname=org.wamblee.glassfish.auth.cache.impl.SimpleExpiryCache
              at java.text.MessageFormat.makeFormat(MessageFormat.java:1339)
              at java.text.MessageFormat.applyPattern(MessageFormat.java:458)
              at java.text.MessageFormat.<init>(MessageFormat.java:350)
              at java.text.MessageFormat.format(MessageFormat.java:811)
              at com.sun.enterprise.server.logging.UniformLogFormatter.uniformLogFormat(UniformLogFormatter.java:272)
              at com.sun.enterprise.server.logging.UniformLogFormatter.format(UniformLogFormatter.java:145)
              at java.util.logging.StreamHandler.publish(StreamHandler.java:179)
              at java.util.logging.ConsoleHandler.publish(ConsoleHandler.java:88)
              at java.util.logging.Logger.log(Logger.java:481)
              at java.util.logging.Logger.doLog(Logger.java:503)
              at java.util.logging.Logger.log(Logger.java:526)
              at java.util.logging.Logger.info(Logger.java:1045)

        Activity

        Erik Brakkee added a comment -
        The cause is that the string which is logged contains characters such as {0} which are interpreted by the java.util.logging. To solve this, we should the logging api with a format string and pass the values as properties to the format string.
        Erik Brakkee added a comment -
        issue has been fixed by using the following logging API

          LOGGER.log(Level.INFO, "Initializing flexible JDBC realm: {0}", aProperties.toString());

        This passes the properties as a parameter to the format string so that {0} in the property values is no longer interpreted by java.util.logging
        Erik Brakkee added a comment -
        verified on gf v3.0.1

          People

          • Assignee:
            Erik Brakkee
            Reporter:
            Erik Brakkee
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: